[LUNI] dependency madness
gug at fnal.gov
Wed Oct 17 15:12:41 CDT 2007
Someone with more experience should comment as I never used Centos,
but I suspect this is an OS version related problem. My experience is
mainly with distributions based on Red Hat Enterprise Linux. I have a
3.x version at home and was unable to build PDFEditor at home because I
had older versions of various packages. I could not get new enough
versions of the packages with yum as for that release I was already up
to date. Manually trying to download and update packages didn't work
either as it would have broken dependencies for other installed
packages. If I would have upgraded to 5.x, then I suspect the problem
would have gone away but I am not quite ready to do that (maybe in a few
more months). Are you running the latest version of Centos?
Richard Reina wrote:
> I don't understand why my glib packages are not update as I did a yum -y update
> a couple of weeks ago.
> Here are my installed glib packages:
> glib.i386 1:1.2.10-15 installed
> glib-devel.i386 1:1.2.10-15 installed
> glib2.i386 2.4.7-1 installed
> glib2-devel.i386 2.4.7-1 installed
> glibc.i686 2.3.4-2.36 installed
> glibc-common.i386 2.3.4-2.36 installed
> glibc-devel.i386 2.3.4-2.36 installed
> glibc-headers.i386 2.3.4-2.36 installed
> glibc-kernheaders.i386 2.4-9.1.100.EL installed
> Gerald Guglielmo <gug at fnal.gov> wrote: Hi,
> Sounds like you have an older version of glib installed and probably
> other related packages. It claims you have 2.4.7 and it requires at
> least 2.8.0. Can you provide a list of glib related packages currently
> installed on your system? Also check which devel packages you have
> installed. The biggest problem I have with compiling packages myself
> that I don't keep my systems on the bleeding edge and some packages
> require that...
> Richard Reina wrote:
>> I am tryiny to install bluetooth-alsa also know as btsco in order to stream audio to my bluetoothe headset. It appears to be cutting edge, atleast to the point that I can't use yum -- I am running Centos. As a result I use the cvs version run the ./bootstrap and then configure. Configure give me this error:
>> checking for pkg-config... /usr/bin/pkg-config
>> checking for glib-2.0 >= 2.8.0, gthread-2.0 >= 2.8.0, gobject-2.0 >= 2.8.0... Requested 'glib-2.0 >= 2.8.0' but version of GLib is 2.4.7
>> configure: error: Library requirements (glib-2.0 >= 2.8.0, gthread-2.0 >= 2.8.0, gobject-2.0 >= 2.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
>> Can someone help me with this I don't know anything about setting variable. I do know that every glib like package is installed.
>> Your beliefs become your thoughts. Your thoughts become your words. Your words become your actions. Your actions become your habits. Your habits become your values. Your values become your destiny. -- Mahatma Gandhi
gug at fnal.gov
Pepe's Theory of everything: "Under the right circumstances, things happen."
More information about the luni